All Apps and Add-ons

Nest Home Thermostat: Mac OS 10.11.1 results in python error "Incompatible library version: etree.so requires version 12.0.0 or later, but libxml2.2.dylib provides version 10.0.0"

jtrujillo
Path Finder

Looks like some Python stuff has moved in El Capitan.

I am now getting a lot of errors (and no data) from the Nest input. Upgraders beware.

11-20-2015 17:54:47.322 -0700 ERROR ExecProcessor - message from "python /Applications/Splunk/etc/apps/nest/bin/nest.py"   Reason: Incompatible library version: etree.so requires version 12.0.0 or later, but libxml2.2.dylib provides version 10.0.0
0 Karma
1 Solution

jtrujillo
Path Finder

Well.... I have no idea what fixed it... Either an OS X update (10.11.3) or a Splunk update (6.3.3) .... But I notice the python is now working again.

View solution in original post

0 Karma

jtrujillo
Path Finder

Well.... I have no idea what fixed it... Either an OS X update (10.11.3) or a Splunk update (6.3.3) .... But I notice the python is now working again.

View solution in original post

0 Karma

fabriziorizzo
Explorer

Anyone have thoughts on how to fix this?

0 Karma
Register for .conf21 Now! Go Vegas or Go Virtual!

How will you .conf21? You decide! Go in-person in Las Vegas, 10/18-10/21, or go online with .conf21 Virtual, 10/19-10/20.