All Apps and Add-ons

Monitoring for Splunk: How to change the default port number?

rsingh
Explorer

i installed Splunk server on my WSUS server (Windows Server 2008) so i need to change the default port. i made the change in C:\Program Files\Splunk\etc\system\local\web but when i check on Splunk to launch the program it points to http://localhost:8000/

WEB config

[settings]
httpport = 12300
mgmtHostPort = 127.0.0.1:12389

if i manually type in http://localhost:12300 i get to login page after i enter the admin and changeme - i get 500 page server error
This page was linked to from http://localhost:12300/en-US/account/login?return_to=%2Fen-US%2F.

0 Karma
1 Solution

hunters_splunk
Splunk Employee
Splunk Employee

Hi rsingh,

Please change the default ports using the following steps:

  1. In Splunk Web, select Settings > Server settings > General Settings from the menu.
  2. Change one or more of the default ports: management port, web port, App server port, KV store port
  3. Click Save.
  4. Restart Splunk for the changes to take effect.

Hope it helps. Thanks.
Hunter

View solution in original post

hunters_splunk
Splunk Employee
Splunk Employee

Hi rsingh,

Please change the default ports using the following steps:

  1. In Splunk Web, select Settings > Server settings > General Settings from the menu.
  2. Change one or more of the default ports: management port, web port, App server port, KV store port
  3. Click Save.
  4. Restart Splunk for the changes to take effect.

Hope it helps. Thanks.
Hunter

View solution in original post

rsingh
Explorer

i was able to get the port changed thanks

0 Karma

rsingh
Explorer

i can't login to change - http://localhost:12300 i get to login page after i enter the admin and changeme - i get 500 page server error
This page was linked to from http://localhost:12300/en-US/account/login?return_to=%2Fen-US%2F.

0 Karma
Register for .conf21 Now! Go Vegas or Go Virtual!

How will you .conf21? You decide! Go in-person in Las Vegas, 10/18-10/21, or go online with .conf21 Virtual, 10/19-10/20.