All Apps and Add-ons

Microsoft Azure Add-ons for Splunk - inputs, configuration pages are not loading


Microsoft Azure Billing and Usage Add-on for Splunk and Splunk Add-on for Microsoft Cloud Services
- for these apps, the inputs page and the configuration are not loading. It shows 'Loading' and doesn't load at all.

Checked permissions and everything is set right.

Can someone please help in fixing this? alt textalt text

Update : This is mostly on the latest version of app and the latest verson of splunk (after Python upgrade).
Older versions are all working fine.


Seems to be the same problem for configurations in Event Hub. It has been fixed by actual ver. 4.1.1

0 Karma


Same here for the Microsoft Azure Add-On for Splunk latest version. The inputs page is just frozen....

0 Karma


I am having the same issue. The only time that it worked is when i had a fresh Splunk install on windows and installed the add-on.

I tried to upgrade the add-on on our linux servers and it did not work, I even tried fresh install of the add-on and still stuck at loading, and creating the inputs on the backend causes 500 server error when loading the UI.

I wonder if @jconger have any recommendation. 


UPDATE: I have a standalone instance where the app is working, and there I see that there are python processes (related to this app) that are connecting to hostname:PORT, but in the instance where the app is not working, it is not even attempting to connect. The connection and port is open but there are no python processes at all. Not sure why the app is not even attempting to connect. 

0 Karma