All Apps and Add-ons

MAXMIND installation problem

Communicator

Hello users,

I recently installed MAXMIND on splunk. The installation took place using the GUI from the Apps->Manage Apps->Install App. Everything seem to be OK however, when I try to launch the module from Manage Apps I get the following error:


ServerSideInclude Module Error!
Splunk has failed to locate the template for uri '/APP/MAXMIND/appserver/static/launcher.html'.

Splunk is installed on Windows Server 2008 R2 just in case this might be of interest.

Do any of you experienced such problems before?

Thank you all,
Evang

0 Karma
1 Solution

Communicator

Hi Evang,

the MAXMIND-App is NOT visible, so there is no need to launch that app - btw. by default it is not visible, because it has no UI (eg. Dashboards)- you only have to install and use it with the lookup-command 🙂

Btw 2: I've tested that app a few days ago and set it visible - but I received no error.

If set to visible and launch the app, a global ("randomly picked" - it loads the first global dashboard in that (app)context - alphanumeric ascending ) dashboard will be loaded - so it is no error on that app itself.

It is recommended by splunk not to set an app without UI to visible - so this may be a side effect 🙂

Greetz, Robert

View solution in original post

0 Karma

Communicator

Hi Evang,

the MAXMIND-App is NOT visible, so there is no need to launch that app - btw. by default it is not visible, because it has no UI (eg. Dashboards)- you only have to install and use it with the lookup-command 🙂

Btw 2: I've tested that app a few days ago and set it visible - but I received no error.

If set to visible and launch the app, a global ("randomly picked" - it loads the first global dashboard in that (app)context - alphanumeric ascending ) dashboard will be loaded - so it is no error on that app itself.

It is recommended by splunk not to set an app without UI to visible - so this may be a side effect 🙂

Greetz, Robert

View solution in original post

0 Karma

Communicator

Hi Rocket66,

I figured out that bit just a few minutes ago. You are right. However, it is not that accurate as I thought. It shows me IP locations incorrectly. Sometimes it even gives geoip info that is more than 400Km wrong. Anyway..

Thanks,
Evang

0 Karma