All Apps and Add-ons

Is Sideview Utils version 3.3 compatible with Splunk version 6.2.X?

ben_leung
Builder

Is Sideview version 3.3 compatible with Splunk version 6.2.X?

I do not see anything mentioning this information in apps.splunk.com or sideviewapps.com

0 Karma
1 Solution

sideview
SplunkTrust
SplunkTrust

Yes it is. I can add an explicit statement to the app's homepage if you like although it seems a little weird. Did something give you the opposite impression somewhere?

View solution in original post

0 Karma

markucsb
Explorer

Not sure if this is related to sideview utils related or 6.2 related or neither, but I upgraded to 6.2 with Search Head Clustering and I'm seeing some odd behavior with the the UseHistory = auto functionality of a dashboard. Intermittently, when I go to one of my sideview utils dashboards I am seeing that some of the panels don't load the pre-run search results even though they show as available and not expired in the jobs page.

0 Karma

sideview
SplunkTrust
SplunkTrust

Can you post the xml in pastebin or something similar or email it to me at nick [at] sideviewapps.com? One thing to double check is that there is a Message module on the page. It could be some other problem for which an error message is coming down, but due to the absence of a Message module, which message might not be getting displayed. Also are any JS errors appearing in the browser's error console?

0 Karma

markucsb
Explorer

I don't think sideview utils is properly handling the UseHistory=Auto setting in 6.2 with Search Head Clustering, if I put this same search in a simple dashboard it loads properly but if I use your sideview utils dashboard it intermittently fails to pull the saved results and instead kicks off a new search. I do have a message module because I see other messages on the page.

0 Karma

sideview
SplunkTrust
SplunkTrust

Interesting. Can you email me at nick [at] sideviewapps.com The code is pretty simple so there's only a few things to try, in order to troubleshoot. I could email you back with a version of SavedSearch.html. Basically the module tries to get the most recent job for the given saved search, when the page loads. The mechanism it uses to do so is fairly simple... but possibly there's some idiosyncracy around search head clustering that it doesn't know about or account for.

0 Karma

sideview
SplunkTrust
SplunkTrust

Yes it is. I can add an explicit statement to the app's homepage if you like although it seems a little weird. Did something give you the opposite impression somewhere?

View solution in original post

0 Karma

ben_leung
Builder

In apps.splunk.com, even though the version is 1.3.5, there is no mention of splunk compatibility for 6.2, but there is in 6.1

Just wanted to be sure 🙂

0 Karma

sideview
SplunkTrust
SplunkTrust

Ah, that helps. The 1.3.5 version is extremely old and out of date. You should be using the latest version which is 3.3.2, and available for free from sideviewapps.com here - http://sideviewapps.com/apps/sideview-utils/

0 Karma

sideview
SplunkTrust
SplunkTrust

An update - since I don't know of anything that would prevent the albeit very old 1.3.5 version from working with Splunk 6.2, I also updated the compatibility in apps.splunk.com to include 6.2.

0 Karma
Register for .conf21 Now! Go Vegas or Go Virtual!

How will you .conf21? You decide! Go in-person in Las Vegas, 10/18-10/21, or go online with .conf21 Virtual, 10/19-10/20.