All Apps and Add-ons

Internal configuration file error. Something wrong within the package or installation step. Contact your administrator f

KeaganJ
Path Finder

I am following the example in this github example:
https://github.com/splunk/Developer_Guidance_Setup_View_Example
In order to get the setup page of my Tech add on working correctly. The add-on previously used a setup.xml in the default folder which would take in a URL and API key.

I have changed the add on to now use html, JS and CSS like the example suggests in the github link above.

Once I have hit the `Submit` button i get presented with the above error whenever trying to navigate to the /inputs endpoint of my TA then the following error message comes up:

 

 Internal configuration file error. Something wrong within the package or installation step. Contact your administrator for support. Detail: instance.pages.configuration.tabs[0].entity[1].type is not one of enum values: text,singleSelect,checkbox,multipleSelect,radio

 

 Watching the logs on both the splunk side and the server side where the API call is being made. I see that the correct URL/domain and API key are being used because the request is going through correctly.

Also looking in the corresponding config file like so:

 

cat etc/apps/TA-canary/local/ta_canary_settings.conf
[additional_parameters]
api_key = ********
canary_domain = <server_domain>
disabled = 0

 

Which is all correct. Following the logs doesn't give any helpful output as to which field is incorrectly in the config files as not one of the following field types like the error says:

 

text,singleSelect,checkbox,multipleSelect,radio

 

 

 

Labels (1)
0 Karma
1 Solution

KeaganJ
Path Finder

Solved the issue myself.

The "type" for the `api_key` in TA-app/appserver/static/js/build/globalConfig.json was set to `password`

Changing that to `text` stopped this error from coming up.

View solution in original post

0 Karma

KeaganJ
Path Finder

Solved the issue myself.

The "type" for the `api_key` in TA-app/appserver/static/js/build/globalConfig.json was set to `password`

Changing that to `text` stopped this error from coming up.

0 Karma
Get Updates on the Splunk Community!

Observability Highlights | January 2023 Newsletter

 January 2023New Product Releases Splunk Network Explorer for Infrastructure MonitoringSplunk unveils Network ...

Security Highlights | January 2023 Newsletter

January 2023 Splunk Security Essentials (SSE) 3.7.0 ReleaseThe free Splunk Security Essentials (SSE) 3.7.0 app ...

Platform Highlights | January 2023 Newsletter

 January 2023Peace on Earth and Peace of Mind With Business ResilienceAll organizations can start the new year ...