All Apps and Add-ons

Insert value into SQL table via dbx application

chimbudp
Contributor

Application:

Splunk db connect

Need:

Need to update a value into SQL table via Splunk dashboard

Query to INSERT a value into SQL table:

| dboutput type=insert database=MyDatabase table=MyTable notFound=insert fields=ColumnName as ColumnValue

| dboutput type=insert database=MyDatabase table=MyTable notFound=insert ColumnName1 as ColumnValue1 CoulmnName2 as CoulumnValue2

Received Error :

command="dboutput", com.splunk.util.csv.CSVException: No CSV input



Tried the above 2 queries , but getting the same Error Message for both

I have already made the database.conf settings. Have set the readonly permission to 'False'

What is the mistake i am making here, am i using the correct format for dboutput query ?

Kindly help.

Tags (3)
0 Karma
1 Solution

cucuro
Explorer

I hope that helps.

| dboutput type=sql database=MyDatabase "INSERT INTO MyTable column, column values column, column"

View solution in original post

jwelsh_splunk
Splunk Employee
Splunk Employee

Here is an actual search command I used and validated it worked:

index=main eventtype="wineventlog-security" | table event_id, EventCode | dboutput database=MSSQLSERVER type=sql "INSERT INTO processes (windows_event_id, windows_event_code) VALUES ($event_id$, $EventCode$)"

Hope it helps.

paulalbert11
Explorer

This was very helpful to me. Thanks!!

0 Karma

cucuro
Explorer

I hope that helps.

| dboutput type=sql database=MyDatabase "INSERT INTO MyTable column, column values column, column"

Got questions? Get answers!

Join the Splunk Community Slack to learn, troubleshoot, and make connections with fellow Splunk practitioners in real time!

Meet up IRL or virtually!

Join Splunk User Groups to connect and learn in-person by region or remotely by topic or industry.

Get Updates on the Splunk Community!

Kick the Tires Before You Commit: A Hands-On Tour of the Splunk Observability Cloud ...

Evaluating an enterprise observability platform usually goes like this: fill out a form, get a free trial with ...

Deep insights, no barriers: Splunk Observability Cloud Free Edition

As software delivery cycles continue to accelerate, observability shouldn’t be a luxury — it should be a ...

Monitoring AI Agents with Splunk Observability Cloud

Let’s say I’m running a travel planning AI app in production. A user asks for three concise hotel options in ...