All Apps and Add-ons

How would I join fields from Splunk DB Connect to DB Input to avoid additional DB lookups?

zhatsispgx
Path Finder

Hello,

I am using Splunk DB Connect -> DB Input to import data from a MySQL Table successfully. Rather than create additional automatic lookups/DB Lookups which will be extremely slow against this massive database, how would I join fields that are already indexed from the DB Input to avoid additional DB Lookups?

DB Input data I would like to join on:

source="nessusdb" field: host_ip with source="suricata" field src_ip.

I would like to take the following fields from source="nessusdb" and add them to a search on source="suricata".

something like:

source="suricata" msg="ET *" | table suricata_event, src_ip, nessus_vulnerability

Sorry in advance I am not very good at SPL yet.

Thanks!

0 Karma
1 Solution

mrgibbon
Contributor

Try using:
index=nessusdb OR source=suricata
then using the coalesce command:
|eval src_ip = coalesce(src_ip,host_ip)
Then put in your table command with src_ip and the other fields.

View solution in original post

0 Karma

mrgibbon
Contributor

Try using:
index=nessusdb OR source=suricata
then using the coalesce command:
|eval src_ip = coalesce(src_ip,host_ip)
Then put in your table command with src_ip and the other fields.

0 Karma
Got questions? Get answers!

Join the Splunk Community Slack to learn, troubleshoot, and make connections with fellow Splunk practitioners in real time!

Meet up IRL or virtually!

Join Splunk User Groups to connect and learn in-person by region or remotely by topic or industry.

Get Updates on the Splunk Community!

[Puzzles] Solve, Learn, Repeat: Matching cron expressions

This puzzle (first published here) is based on matching timestamps to cron expressions.All the timestamps ...

Design, Compete, Win: Submit Your Best Splunk Dashboards for a .conf26 Pass

Hello Splunkers,  We’re excited to kick off a Splunk Dashboard contest! We know that dashboards are a primary ...

May 2026 Splunk Expert Sessions: Security & Observability

Level Up Your Operations: May 2026 Splunk Expert Sessions Whether you are refining your security posture or ...