All Apps and Add-ons

How to set up the EMC Isilon App & Add-on for Splunk Enterprise?

Path Finder

I've tried on a distributed setup as well as just a single host test instance that has TCP connectivity to the target storage frame's API (for example https://192.168.1.100:8080 ). I'm running a tcpdump after I input the storage address with validated credentials but never see any TCP communication after restarting splunk. Greping ps as well, I do not see any running python scripts from the app initiated or attempting to connect to the Isilon.

Addon https://splunkbase.splunk.com/app/2689/
App https://splunkbase.splunk.com/app/2688/
alt text

-single host is on 6.3 which might not be officially supported by app yet
/opt/splunk/bin/splunk version
Splunk 6.3.1 (build f3e41e4b37b2)

-python version included with 6.3.1 is below
/opt/splunk/bin/python --version
Python 2.7.9

I've also tried inputing and escaping the IP address after setup within the passwords.conf stanza

Methods I've tried for input(screenshot attached) of the ip address example https://192.168.1.100:8080 are...
- 192.168.1.100
- 192.168.1.100:8080
- https://192.168.1.100:8080

Between attempts I would remove the local/app & local/passwords conf that are created upon "setup" and restart splunk. I never saw any TCP communication or python process associated with the path of the app launching after "setup" of the addon.

/opt/splunk/etc/apps/TA_EMC-Isilon/local/app.conf
/opt/splunk/etc/apps/TA_EMC-Isilon/local/passwords.conf

At this point I suspect its something wrong with the way the app is calling the python, I'm just not familiar enough to test or prove it at this point.

1 Solution

Path Finder

Wow so the fix was so easy its kind of embarrassing, but I'll take it! Essentially had to just turn on the scripts to start inputting. Was able to get this working on Splunk 6.3.2 (App currently validated for 6.2) although I haven't checked full App functionality yet, looks promising.

  1. Go to "Settings"
  2. Under "Local Inputs" go to "Scripts"
  3. Under the status column "Enable" the scripts of interest
  4. List item alt text

View solution in original post

0 Karma

Path Finder

Wow so the fix was so easy its kind of embarrassing, but I'll take it! Essentially had to just turn on the scripts to start inputting. Was able to get this working on Splunk 6.3.2 (App currently validated for 6.2) although I haven't checked full App functionality yet, looks promising.

  1. Go to "Settings"
  2. Under "Local Inputs" go to "Scripts"
  3. Under the status column "Enable" the scripts of interest
  4. List item alt text

View solution in original post

0 Karma