All Apps and Add-ons

How to debug connection errors on Windows 7 64bit using the Splunk ODBC 64bit driver with 64bit Excel?

Ultra Champion

Any ideas on how to enable any log/debug for the 64-bit version of the Splunk ODBC driver?

Similar to http://answers.splunk.com/answers/119435/splunk-odbc-32-bit-on-windows-7-64-bit.html, I'm trying to debug some connection errors on Windows 7 64bit, using the ODBC 64bit driver with 64bit Excel.

Does anyone know the registry path for changing the LogLevel and LogPath for 64bit ODBC connector?

I tried HKEY_LOCAL_MACHINE\SOFTWARE\Wow6432Node\Splunk ODBC Driver\Driver but I see no results in fiddler or the LogPath.

I also tried LogLevel set to 9 but Fiddler was not capturing the results. I do have an https_proxy Environment Variable set.

0 Karma
1 Solution

Splunk Employee
Splunk Employee

The reg key path with "Wow6432Node" is for 32 bit driver. Please try HKEYLOCALMACHINE\SOFTWARE\Splunk ODBC Driver\Driver

View solution in original post

Splunk Employee
Splunk Employee

The reg key path with "Wow6432Node" is for 32 bit driver. Please try HKEYLOCALMACHINE\SOFTWARE\Splunk ODBC Driver\Driver

View solution in original post

Splunk Employee
Splunk Employee

I think the best way would be to try using curl command line to connect. Note that it will use https_proxy environment variable. Please check the following:

  1. In server.conf, do you have the below? If so, try removing that line. Latest release of ODBC driver contains a fix to this issue.
    supportSSLV3Only = True

  2. Make sure your splunk server instance does not require SSL client certificate.

Let me know if you have more questions. Thanks.

0 Karma

Ultra Champion

Unfortunately I'm not experiencing any problems connecting with curl and we don't have those settings and I'm not seeing anything with the debugging enabled. Therefore I've opened case 206312 for the deeper connectivity challenge. Thanks!

0 Karma

Splunk Employee
Splunk Employee

Another thing to look into is whether there's a proxy in the middle.

Once we allowed SSLV3 to pass through the proxy server, it works as promised.

0 Karma

Ultra Champion

That worked well and I see a log. Unfortunately, Fiddler still is getting nothing. Can you think of any reason why fiddler is not capturing the data? Has the fiddler compatibility been removed?

I'm trying to debug this error message: [40] Error with HTTP API, error code: SSL connect error

I have no issue connecting to other internal and external facing splunk environments with this set up.

0 Karma