All Apps and Add-ons

How do I resolve this error: MISP APP API SSL: CERTIFICATE_VERIFY_FAILED

gordonblei
New Member

Hello,

 

i have setup the  MISP42 | Splunkbase app and i want splunk to use the ssl connection to MISP.

My certificate is issued by lets encrypt for MISP and SPLUNK. 

i have copied the fullchain.pem and crt from MISP to SPLUNK

But is still get the following error after enabling "check MISP certificate" 

External search command 'mispgetevent' returned error code 1. Script output = "error_message=SSLError at "/opt/splunk/lib/python3.7/site-packages/requests/adapters.py", line 514 : HTTPSConnectionPool(host='FQDN', port=443): Max retries exceeded with url: /events/restSearch (Caused by SSLError(SSLCertVerificationError(1, '[SSL: CERTIFICATE_VERIFY_FAILED] certificate verify failed: unable to get issuer certificate (_ssl.c:1106)'))) ". 

Thanks in advance for your help

Labels (2)
Tags (1)
0 Karma

xamanium
Explorer

Had you resolved this issue? 
I had the same problem. I just export the Certificate form MISP and added it to splunk python CA store.

0 Karma
Got questions? Get answers!

Join the Splunk Community Slack to learn, troubleshoot, and make connections with fellow Splunk practitioners in real time!

Meet up IRL or virtually!

Join Splunk User Groups to connect and learn in-person by region or remotely by topic or industry.

Get Updates on the Splunk Community!

Event Series: Level up your SOC: Advancing with Splunk Enterprise Security

AI has fundamentally raised the stakes for security operations, and this three-part series is your guide to ...

Announcing Modern Navigation: A New Era of Splunk User Experience

We are excited to introduce the Modern Navigation feature in the Splunk Platform, available to both cloud and ...

SOC4Kafka - New Kafka Connector Powered by OpenTelemetry

The new SOC4Kafka connector, built on OpenTelemetry, enables the collection of Kafka messages and forwards ...