All Apps and Add-ons

Google Workspace for Splunk addon throws error

rvsoni
Engager

Hello @alacercogitatus 

Google Workspace for Splunk addon throws an error

Installed Add ons "Google Workspace for Splunk" configured google workspace account,

able to see the users list in splunk,

"Admin SDK Reports Ingest" configuration throws below error

for service "login" and "user_account"

error_message="invalid literal for int() with base 10: '1636719173.276311'" error_type="<class 'ValueError'>" error_arguments="invalid literal for int() with base 10: '1636719173.276311'" error_filename="google_client.py" error_line_number="863" input_guid="840262-6716-ff73-e5c-c0816800774" input_name="Account"

Labels (1)
0 Karma

rvsoni
Engager

@alacercogitatusThanks for the prompt reply,

I will wait for version 1.5.4 to be available to deploy

Thanks,

Ravi

0 Karma

alacercogitatus
SplunkTrust
SplunkTrust

That is a debug log line. Remove lines 862 and 863 from google_client.py. I'll fix it in 1.5.4. Thanks.

rvsoni
Engager

Hi @alacercogitatus

 

Any update on this issue?

 

Thanks,

Ravi

0 Karma

rvsoni
Engager

@alacercogitatusThanks for the prompt reply,

I will wait for version 1.5.4 to be available to deploy.

Do I need to create a ticket for this issue?

Any timeline for this fix.

Thanks,

Ravi

0 Karma
Got questions? Get answers!

Join the Splunk Community Slack to learn, troubleshoot, and make connections with fellow Splunk practitioners in real time!

Meet up IRL or virtually!

Join Splunk User Groups to connect and learn in-person by region or remotely by topic or industry.

Get Updates on the Splunk Community!

Vibe-coding, AI, and Splunkcraft: Highlights from the .conf26 Builder Bar

If you stopped by the Builder Bar at .conf26, thank you! This year, we brought ...

Thanks for the Memories: .conf26 Took Learning to New Heights

Thank you, Splunk Community, for making .conf26 in Denver one for the books. From packed Splunk University ...

Best Practices: Splunk auto adjust pipeline queue

When you enable autoAdjustQueue in Splunk, maxSize should be understood as the queue size Splunk starts with ...