All Apps and Add-ons

ERROR ExecProcessor - message from "python /opt/splunk/etc/apps/SPLUNK4JMX/bin/jmx.py" Error executing JMX stanza jmx://XXXX : No such attribute: yyyy

davideperego
Engager

Hello,
I'm getting tons of these messages in splunkd.log.

ERROR ExecProcessor - message from "python /opt/splunk/etc/apps/SPLUNK4JMX/bin/jmx.py" Error executing JMX stanza jmx://CONFIGNAME : No such attribute: attributename

I know the best is to remove the missing attributes from the xml configuration (I have hundreds of xml running), but can I filter out the messages of this type and avoid filling the log and _internal index ?

Thanks

1 Solution

Damien_Dallimor
Ultra Champion

The default config.xml that ships with the App is merely an example. I've tried to make it as generic as possible , but there may well be MBean attributes declared that are not relevant to your JVM runtime. So you will have to remove them from your config file.

View solution in original post

Damien_Dallimor
Ultra Champion

The default config.xml that ships with the App is merely an example. I've tried to make it as generic as possible , but there may well be MBean attributes declared that are not relevant to your JVM runtime. So you will have to remove them from your config file.

davideperego
Engager

I understand the need to correct config.xml, actually it's not my job editing it because activity is from another team, but I would like to find a way to filter out this kind of noise... _internal index growing more than actual data is a real problem to me.
Thanks, Davide

0 Karma

Damien_Dallimor
Ultra Champion

You will have to find who's job it is to edit it.
It is their responsibility to set up the config.xml file correctly.
That is the root cause of the problem you need to address.
Then , you won't see these genuine error messages.

0 Karma
Got questions? Get answers!

Join the Splunk Community Slack to learn, troubleshoot, and make connections with fellow Splunk practitioners in real time!

Meet up IRL or virtually!

Join Splunk User Groups to connect and learn in-person by region or remotely by topic or industry.

Get Updates on the Splunk Community!

SOC4Kafka - New Kafka Connector Powered by OpenTelemetry

The new SOC4Kafka connector, built on OpenTelemetry, enables the collection of Kafka messages and forwards ...

Event Series: Level up your SOC: Advancing with Splunk Enterprise Security

AI has fundamentally raised the stakes for security operations, and this three-part series is your guide to ...

Announcing Modern Navigation: A New Era of Splunk User Experience

We are excited to introduce the Modern Navigation feature in the Splunk Platform, available to both cloud and ...