All Apps and Add-ons
Highlighted

DB Connect 3.3.0 - Cannot communicate with task server, please check your settings

Explorer

I've combed through many similar questions, but no resolutions thus far have worked for me:

Issue:
- unable to get past http://servername:8000/en-US/app/splunk_app_db_connect/ftr#/welcome
- Upon first launch of the App, an error briefly pops up: "Cannot communicate with task server, please check your settings"
- In output of: "./splunk cmd splunkd print-modinput-config --debug server" I see:

===================================================
Found scheme="server".
Locating script for scheme="server"...
Found script "/opt/splunk/etc/apps/splunkappdbconnect/linuxx8664/bin/server.sh" to handle scheme "server".
Introspecting scheme=server: /usr/lib/jvm/java-11-openjdk-amd64/bin/java: symbol lookup error: /usr/lib/jvm/java-11-openjdk-amd64/bin/java: undefined symbol: JLI
InitArgProcessing
Introspecting scheme=server: script running failed (exited with code 127).

Unable to initialize modular input "server" defined in the app "splunkappdb_connect": Introspecting scheme=server: script running failed (exited with code 127)..

What I've tried thus far:
- manually uninstalled and reinstalled the App, and restarting splunk
- added:
/etc/ld.so.conf.d/java.conf -- With the single-line contents (added to new Docker image):
/usr/lib/jvm/java-11-openjdk-amd64/lib/jli

System:
Splunk 8.0.3, dockerized on Debian 10
Open JDK 11
DB Connect 3.3.0
JAVA_HOME is set to: /usr/lib/jvm/java-11-openjdk-amd64/

0 Karma
Highlighted

Re: DB Connect 3.3.0 - Cannot communicate with task server, please check your settings

Communicator

Hi

Have you tried using JRE 8 or OpenJDK 8 instead of 11. Have you checked this answer https://answers.splunk.com/answers/507416/splunk-db-connect-how-to-resolve-can-not-communica.html?

Hope it helps.

0 Karma
Highlighted

Re: DB Connect 3.3.0 - Cannot communicate with task server, please check your settings

Explorer

I'd have to go to an older version of Debian in order to natively get Open JDK (using apt) as only version 11 is available for Debian 10... I'm not too keen on having to do this for something I'm currently using in production (and would have to do a bunch of testing for). I considered it, but seems/feels counter-intuitive...

I believe I came across that article, but haven't attempted changing the port for DB Connect... I'll give that a try in the morning... thx!

0 Karma
Highlighted

Re: DB Connect 3.3.0 - Cannot communicate with task server, please check your settings

Explorer

Getting a little further... dbxtaskserver is actually starting now, and have confirmed the tcp/9998 is listening now... but I am still getting the same error when trying to get into the DB Connect app (cannot communicate with task server)

2020-04-27 18:01:46.266 +0000 1758@ip-xx.xx.xx.xxx.eu-west-2.compute.internal [main] INFO io.dropwizard.server.ServerFactory - Starting dbxtaskserver

In order to get this far, installed OpenJDK 8 from "adoptopenjdk"

0 Karma
Highlighted

Re: DB Connect 3.3.0 - Cannot communicate with task server, please check your settings

Explorer

I'm able to get into the Splunk DB Connect page now.

In: /opt/splunk/etc/apps/splunkappdbconnect/local
1. Added file: app.conf
2. Added stanza to file:
[install]
is
configured = 1
3. restarted splunk

I'm able to get in now

View solution in original post

0 Karma