All Apps and Add-ons

Create Oracle Connection: Cannot load connection class because of underlying exception: com.mysql.cj.exceptions.WrongArgumentException: Malformed database URL, failed to parse the main URL sections.

New Member

On save of the connection a strange MySQL related error is shown although I am creating an Oracle connection. This worked fine in the previous version of db connect.

Version 3.1.4, must be related to pi

Tags (1)
0 Karma


I had the same problem in Splunk and DB-Connect 3.2.0
I tried to made a new Oracle-DB-Connection and got mySQL error message. When I removed mySQL driver from DB-Connect I got the correct error message from Oracle jdbc driver.
As suggested by earlhelms it seems to be a bug in the mySQL jdbc driver, so I updated this driver from version 8.0.11 to 8.0.19 and this seems to solve the issue.

0 Karma

Path Finder

This appears to be related -

Bug #87600 Connector throws 'Malformed database URL' on non mysql connection-urls

Incidentally, only one of may many Oracle databases is having this issue and it only started following an Oracle upgrade.

Path Finder

I'm having the same issue and it only started after an Oracle database upgrade. An existing working database input started displaying this message and stopped working.

0 Karma
.conf21 CFS Extended through 5/20!

Don't miss your chance
to share your Splunk
wisdom in-person or
virtually at .conf21!

Call for Speakers has
been extended through
Thursday, 5/20!