All Apps and Add-ons

Code42 402 Errors for API calls

frankwayne
Path Finder

When the input add-on calls the below API URL, it gets a 402 error. (About 100,000 at a time, in our case.) What is the missing licensing requirement? And how would you turn this off, if you weren't licensed for it?

https://<host>:4285/c42api/v3/SecurityEventsLocation?userUid=<some-uid>;
0 Karma
1 Solution

aplura_llc_supp
Communicator

If you are not licensed for Security Events (to determine your licensing levels, please contact Code42 Sales), or to remove the errors, you need to uncheck the Security box from the Modular Input configuration. Those calls are only made during collection of security events.

alt text

View solution in original post

aplura_llc_supp
Communicator

If you are not licensed for Security Events (to determine your licensing levels, please contact Code42 Sales), or to remove the errors, you need to uncheck the Security box from the Modular Input configuration. Those calls are only made during collection of security events.

alt text

frankwayne
Path Finder

Thank you. That solved the problem.

0 Karma
Got questions? Get answers!

Join the Splunk Community Slack to learn, troubleshoot, and make connections with fellow Splunk practitioners in real time!

Meet up IRL or virtually!

Join Splunk User Groups to connect and learn in-person by region or remotely by topic or industry.

Get Updates on the Splunk Community!

Thanks for the Memories: .conf26 Took Learning to New Heights

Thank you, Splunk Community, for making .conf26 in Denver one for the books. From packed Splunk University ...

Best Practices: Splunk auto adjust pipeline queue

When you enable autoAdjustQueue in Splunk, maxSize should be understood as the queue size Splunk starts with ...

Splunk Auto Ingestion Parallel Pipeline Scaling

Why this feature matters Many Splunk environments experience ingestion pressure long before the host is fully ...