All Apps and Add-ons

Centos7: How do I get dependencies installed properly?


When I enable/disable the input it pulls in new events, but it throws the below errors.
If I leave it enabled and it stops pulling in logs after the first attempt.




/splunk/etc/apps/sft-audit-events-splunk/bin/", "Got events: " + results.getAndEmitEvents.list.length

"Dependencies This modular input
depends on a couple of npm modules:
1. request - Apache 2.0
2. async - MIT
3. splunk-sdk - Apache 2.0
4. parse-link-header - MIT"

0 Karma

Community Manager
Community Manager

Hi @cybersecnutant ,

Did you have a chance to check out @richgalloway 's answer? If it worked, please resolve this post by approving it! If your problem is still not solved, keep us updated so that someone else can help you.

Thanks for posting!

0 Karma


Talk to your Linux system admin about installing the dependencies. Give him/her the links from the splunkbase page. Don't forget to have him/her install NodeJS, too.

If this reply helps you, Karma would be appreciated.
0 Karma
Get Updates on the Splunk Community!

Streamline Data Ingestion With Deployment Server Essentials

REGISTER NOW!Every day the list of sources Admins are responsible for gets bigger and bigger, often making the ...

Remediate Threats Faster and Simplify Investigations With Splunk Enterprise Security ...

REGISTER NOW!Join us for a Tech Talk around our latest release of Splunk Enterprise Security 7.2! We’ll walk ...

Introduction to Splunk AI

WATCH NOWHow are you using AI in Splunk? Whether you see AI as a threat or opportunity, AI is here to stay. ...