All Apps and Add-ons

Application is disabled: Splunk_TA_ontap

Path Finder

Getting this error when trying to set netapp add on.
Any idea?

2019-11-11 22:47:30,339 ERROR [ta_ontap_collection_scheduler://nidhogg] Problem with hydra scheduler ta_ontap_collection_scheduler://nidhogg:
 [HTTP 404] https://splunkDCN01.lab.loc:8089/servicesNS/nobody/Splunk_TA_ontap/data/inputs/ta_ontap_collection_w...; [{'text': 'Application is disabled: Splunk_TA_ontap', 'code': None, 'type': 'ERROR'}]
Traceback (most recent call last):
  File "/opt/splunk/etc/apps/SA-Hydra/bin/hydra/hydra_scheduler.py", line 2108, in run
    self.node_manifest = self.establishNodeManifest()
  File "/opt/splunk/etc/apps/SA-Hydra/bin/hydra/hydra_scheduler.py", line 2035, in establishNodeManifest
    metadata_dict=self.metadata_dict, worker_input_name=self.worker_input_name)
  File "/opt/splunk/etc/apps/SA-Hydra/bin/hydra/hydra_scheduler.py", line 826, in __init__
    self.heads_list = self.establishHeads()
  File "/opt/splunk/etc/apps/SA-Hydra/bin/hydra/hydra_scheduler.py", line 1176, in establishHeads
    sessionKey=self.session_key, hostPath=self.node_path)
  File "/opt/splunk/lib/python2.7/site-packages/splunk/entity.py", line 137, in getEntities
    atomFeed = _getEntitiesAtomFeed(entityPath, namespace, owner, search, count, offset, sort_key, sort_dir, sessionKey, uri, hostPath, **kwargs)
  File "/opt/splunk/lib/python2.7/site-packages/splunk/entity.py", line 230, in _getEntitiesAtomFeed
    serverResponse, serverContent = rest.simpleRequest(uri, getargs=kwargs, sessionKey=sessionKey, raiseAllErrors=True)
  File "/opt/splunk/lib/python2.7/site-packages/splunk/rest/__init__.py", line 550, in simpleRequest
    raise splunk.ResourceNotFound(uri, extendedMessages=extractMessages(body))
ResourceNotFound: [HTTP 404] https://splunkDCN01.lab.loc:8089/servicesNS/nobody/Splunk_TA_ontap/data/inputs/ta_ontap_collection_w...; [{'text': 'Application is disabled: Splunk_TA_ontap', 'code': None, 'type': 'ERROR'}]
0 Karma
1 Solution

Path Finder

The error was because the app in the heavy forwarder (the DCN) is disabled by default. Need to enable it.

View solution in original post

0 Karma

Path Finder

The error was because the app in the heavy forwarder (the DCN) is disabled by default. Need to enable it.

View solution in original post

0 Karma

Path Finder

Which version of splunk are you using? in the new Splunk Version 8.0, python support for 2.7 has been deprecated.

Check this out: https://docs.splunk.com/Documentation/Splunk/latest/Python3Migration/AboutMigration

0 Karma

Path Finder

7.3.2
The same DCN is used for vmware collection just fine btw.

0 Karma