Alerting

Webproxy search help

fdevera
Path Finder

Hi I've got this webproxy ES base search where I'm trying to show high number of destinations from a low number of sources. I would also like to throttle the search by going back 24hr, then only looking at the most recent time. How best to do that?

| tstats `summariesonly` count min(_time) as first_seen max(_time) as last_seen values(Web.action) as Web.action from datamodel=Web.Web WHERE index=webproxy Web.action=allowed
by Web.src Web.dest
| `drop_dm_object_name("Web")`
| convert ctime(*_seen)
| lookup dnslookup clientip AS dest OUTPUT clienthost AS dest_host
| lookup dnslookup clientip AS src OUTPUT clienthost AS src_host
| search NOT src_host=drekar-rancher-ccena*
| sort - count

 

Labels (2)
Tags (1)
0 Karma

fdevera
Path Finder

Bump

0 Karma
Got questions? Get answers!

Join the Splunk Community Slack to learn, troubleshoot, and make connections with fellow Splunk practitioners in real time!

Meet up IRL or virtually!

Join Splunk User Groups to connect and learn in-person by region or remotely by topic or industry.

Get Updates on the Splunk Community!

Persistent Queue at TcpOut — One of Splunk's Most Practical Features

Splunk introduced persistent queueing at the tcpout layer as one of the most practical resilience features in ...

Build resilience for the agentic era: Join us at Splunk Go San Jose

AI is changing how organizations build, operate, and secure digital services. As teams adopt AI agents and ...

Manage Edge Processor pipelines end to end with APIs

This guide uses the Data Management APIs to create an Edge Processor, onboard one instance, deploy a pipeline ...