Alerting

Splunkhec urI

santysanthosh
New Member

Hi

 

Actually am trying to integrate splunk with camel-kafka-connnector and i have configured all and everything works fine expect the "splunkhec URI "  Am facing the issue that the " Failed to resolve endpoint: splunk-hec:" " Invalid URI: splunk-hec:" can any one help me to resolve this issue

apiVersion: kafka.strimzi.io/v1beta2
kind: KafkaConnector
metadata:
name: strimzi
labels:
strimzi.io/cluster: strimzi
spec:
class: org.apache.camel.kafkaconnector.splunkhec.CamelSplunkhecSinkConnector
tasksMax: 1
config:
topics: kafka-test3
key.converter: org.apache.kafka.connect.storage.StringConverter
value.converter: org.apache.kafka.connect.storage.StringConverter
#key.converter: org.apache.kafka.connect.json.JsonConverter
#value.converter: org.apache.kafka.connect.json.JsonConverter
key.converter.schemas.enable: false
value.converter.schemas.enable: false

camel.sink.path.splunkURL: 'http://<IP>:<port>/services/collector'

camel.sink.path.token: 'XXXXXXXXXXXXXXxx'

Labels (1)
0 Karma
Register for .conf21 Now! Go Vegas or Go Virtual!

How will you .conf21? You decide! Go in-person in Las Vegas, 10/18-10/21, or go online with .conf21 Virtual, 10/19-10/20.