Alerting

Sendemail "Invalid address" error while sending scheduled report via email after upgrading to 8.1.3

AshChakor
Path Finder

I have scheduled reports which sends pdf via sendemail. But After upgrading Splunk to 8.1.3 its not working, I am  seeing "Invalid address" error as below

112 -0400 ERROR sendemail:522 - (501, b'5.1.7 Invalid address', 'SPLUNK@serverdomainname') while sending mail to: abc@xyz.com
 
Is there any way that I can change the "From" address?
 
Thanks in advance!
Labels (1)
0 Karma

FredChauviere
New Member

I got a non-similar but related problem:
Alert emails were not sent anymore after a major upgrade 6.6.0 => 7.2.1 (with machine transfer) => 8.1.4 => 8.2.2 (I know, we postponed our upgrade a bit too much 😉 )

So I could not know exactly which version "broke" our email sending.

But after several try and error, I figured that the "from" from email stanza in  $SPLUNK_HOME$\etc\system\local\alert_actions.conf (or Send emails as field in Settings > Server settings > Email settings) was containing a string "Splunk Server B102", perfectly supported in 6.6.0, but 8.2.2 did not agree with string containing space: after replacing the string with "Splunk_Server_B202" everything was back online!

So that was a weird one... (regression from my point of view)

Tags (1)
0 Karma

burwell
SplunkTrust
SplunkTrust

Did you try providing an alert_actions.conf with the from address?

[email]
from = foo@bar.com

Tags (1)
0 Karma
Get Updates on the Splunk Community!

Maximize the Value from Microsoft Defender with Splunk

 Watch NowJoin Splunk and Sens Consulting for this Security Edition Tech TalkWho should attend:  Security ...

This Week's Community Digest - Splunk Community Happenings [6.27.22]

Get the latest news and updates from the Splunk Community here! News From Splunk Answers ✍️ Splunk Answers is ...

Reminder! Splunk Love Promo: $25 Visa Gift Card for Your Honest SOAR Review With ...

We recently launched our first Splunk Love Special, and it's gone phenomenally well, so we're doing it again, ...