Alerting

Regroup Alerts

honolulu95
New Member

Hello, please i need to know how i can create an alert that groups together several other alerts.
Or Maybe to create an alert regrouping 2 or 3 event logs in splunk.
Thank you.

Labels (1)
0 Karma

gcusello
SplunkTrust
SplunkTrust

Hi @honolulu95,
could you better describe your need?

In Splunk every alert, report or dashboard panel is a search; so you cannot group more alerts, but maybe (I don't know your requirement) it's possible to create a search that contains the searches of more alerts.
e.g. if you need to check if there are logs from two different sources (eventually stored in different indexes), you don't need to create two alerts, you can create an alert that checks the two sources.
e.g. events from Windows and Linux OSs, stored in os and wineventlog index:

index=os OR index=wineventlog
| stats dc(index) AS count 
| where count<2

Ciao.
Giuseppe

0 Karma

to4kawa
Ultra Champion

There's no such feature.

0 Karma
Got questions? Get answers!

Join the Splunk Community Slack to learn, troubleshoot, and make connections with fellow Splunk practitioners in real time!

Meet up IRL or virtually!

Join Splunk User Groups to connect and learn in-person by region or remotely by topic or industry.

Get Updates on the Splunk Community!

Tuning Edge Processor in Hybrid Mode: What Limits Each Data Path

When you run Edge Processor in hybrid mode, alongside a Splunk heavy forwarder on the same host, two questions ...

Best Practices: Splunk auto adjust pipeline queue

When you enable autoAdjustQueue in Splunk, maxSize should be understood as the queue size Splunk starts with ...

Request for Professional Development: Attending .conf26

Winning Over the Boss: Your Pass to .conf26 conf26 is going to be here before you know it. If don't already ...