Splunk Search
Highlighted

timechart automatic scaling 6.3

Path Finder

I have dashboards that show various metrics over a time window. It appears that in 6.3 the timecharting display is set to automatically scale to the window that has data, instead of the window of the search.

I want ot see flatline (zero data) leading up to and out of "issues" in my timecharts, however 6.3 seems to be "smart" and automatically zoom in, if there is no data at the begingin or end of the timeseries.

I'm looking through docs and UI choices, however I can not find a place to turn off this "feature".

0 Karma
Highlighted

Re: timechart automatic scaling 6.3

Esteemed Legend

If you cannot find a way to turn it off, you can tack this on your search to create an itty-bitty event at both ends (you may need to adjust the field names some):

... | append [| noop | stats count | eval host="DUMMY_DATA_IGNORE_ME" | eval count = split("0.0001,0.0002",",") | mvexpand count | addinfo | eval _time=if(count="0.0001", info_min_time, info_max_time) | fields - info*]