Splunk Search

splunk query drops off results after query has finished

Explorer

I had a query that was working perfectly until recently where it started cutting off the last 4 days of data just for one grouping for the "Live" category. The odd thing is it only disapeers the results right before the query has completed otherwise it computes the results almost all the way to the end.

as query begins:
http://cl.ly/image/3a27251m0C0w

right before completion:
http://cl.ly/image/2j3b360c3C3u

here is the query:
* searchname="EXEC: New Users By Label (daily) (summary index)" index="summary" | stats count(valueuserdeviceudid) as newusers by _time, label | streamstats sum(newusers) as totalusers by _time,label | eval live=if(totalusers >= 100, "Live", "Pending") | stats values(label) as labelvalues count as dailycount by time, live | streamstats dc(labelvalues) as total_apps by live.

I've doubled the limits for the following in limits.conf:

[searchresults]
maxresultrows = 100000

maxstreamwindow = 30000

[stats]
maxresultrows = 100000

Tags (2)
0 Karma
1 Solution

Explorer

Turns out I didn't actually save my limits.conf when I changed the following config:

[stats]
maxresultrows = 100000

turns out doubling the stats resultrows worked and now I get all my entire results set.

View solution in original post

0 Karma

Explorer

Turns out I didn't actually save my limits.conf when I changed the following config:

[stats]
maxresultrows = 100000

turns out doubling the stats resultrows worked and now I get all my entire results set.

View solution in original post

0 Karma