Splunk Search

output lookup search correlation with input lookup data

brdr
Contributor

Hello, can you use a output lookup table just after creating it? I have this search...

index=indexA sourcetype=mystA | table src | outputlookup new.csv
| search index=indexB sourcetype=mystB [| inputlookup new.csv | rename src as src_ip ]
| table user
| lookup user.csv AS user OUTPUT displayName

When I run this I get no data found, however, when I separate out the outputlookup command and the subsearch and run I get results as expected.

0 Karma

brdr
Contributor

reposted initially as an Answer: reposting as a comment:

My use case is:
I need a count of users by there business units. To do this I do:
output list IPs as seen in blue coat logs
index=indexA sourcetype=mystA | table src | outputlookup new.csv
using this list (new.csv) match on IP to get user name from our authentication data (indexB) to display business unit
| search index=indexB sourcetype=mystB [| inputlookup new.csv | table src | rename src as src_ip ]
| table user
| lookup user.csv uname as user OUTPUT displayName businessUnit
| stats count by businessUnit

0 Karma

brdr
Contributor

My use case is:

I need a count of users by there business units. To do this I do:

  • output list IPs as seen in blue coat logs
    index=indexA sourcetype=mystA | table src | outputlookup new.csv

  • using this list (new.csv) match on IP to get user name from our authentication data (indexB) to display business unit
    | search index=indexB sourcetype=mystB [| inputlookup new.csv | table src | rename src as src_ip ]
    | table user
    | lookup user.csv uname as user OUTPUT displayName businessUnit
    | stats count by businessUnit

0 Karma

somesoni2
Revered Legend

I don't think you can do that. What's your use case here?

0 Karma
Got questions? Get answers!

Join the Splunk Community Slack to learn, troubleshoot, and make connections with fellow Splunk practitioners in real time!

Meet up IRL or virtually!

Join Splunk User Groups to connect and learn in-person by region or remotely by topic or industry.

Get Updates on the Splunk Community!

Index This | What travels the world but is also stuck in place?

April 2026 Edition  Hayyy Splunk Education Enthusiasts and the Eternally Curious!   We’re back with this ...

Discover New Use Cases: Unlock Greater Value from Your Existing Splunk Data

Realizing the full potential of your Splunk investment requires more than just understanding current usage; it ...

Continue Your Journey: Join Session 2 of the Data Management and Federation Bootcamp ...

As data volumes continue to grow and environments become more distributed, managing and optimizing data ...