Splunk Search

mutiple search

riposans
Explorer

Hello everyone,

 i need solution for this.

my data :

userID=text123 , login_time="2024-03-21 08:04:42.201000", ip_addr=12.3.3.21

userID=text123, login_time="2024-03-21 08:00:00.001000", ip_addr=12.3.3.45

userID=text123, login_time="2024-03-21 08:02:12.201000", ip_addr=12.3.3.21

userID=text123, login_time="2024-03-21 07:02:42.201000", ip_addr=12.3.3.34

 

i want get data, userID="text123 " AND in the last 5 minutes AND if mutiple ip

i used join,map,append but not solved.please help for SPL this

Labels (1)
0 Karma

bowesmana
SplunkTrust
SplunkTrust

Try this - use your index and I assume that the event _time stamp is the login time.

index=bla userID=text123 earliest=-5m@m latest=@m
| stats dc(ip) as ips by userID
| where ips>1

If your events contain other info than just login details, then you may need to add login_time=* to the search

0 Karma
Got questions? Get answers!

Join the Splunk Community Slack to learn, troubleshoot, and make connections with fellow Splunk practitioners in real time!

Meet up IRL or virtually!

Join Splunk User Groups to connect and learn in-person by region or remotely by topic or industry.

Get Updates on the Splunk Community!

Meet the .conf26 AI Agent Buildathon Winners

At the .conf26 AI Agent Buildathon, Splunk users turned their operational expertise into working AI agents ...

Trusted Autonomy in the SOC: A Maturity Journey

AI is compressing attacker timelines and pushing SOC teams beyond human capacity thresholds. The next SOC ...

Supercharging Windows Security Detection Performance: Introducing Hybrid Field ...

Windows event logs—from Security auditing and Sysmon to PowerShell script blocks—form the operational backbone ...