Splunk Search

iis field extraction uri="-"

Motivator

So I am extracting fields using the standard field transforms, and many of my uri results and user agents are returning the value: "-"

There is useful data there, so I am attempting to figure out why this is happening if i'm using the standard field extraction / transforms.

Please see examples of config below:
Log String:

2013-04-22 17:05:48 W3SVC195900357 POST - 443 - HTTP/1.1 Mozilla/4.0+(compatible;+MSIE+6.0;+MS+Web+Services+Client+Protocol+2.0.50727.5466) - - 200 0 0 1278 700 10

Results for field URI="-"

PROPS.CONF

[iis]

[REPORT-iis = iisloggingcombined]

TRANSFORMS.CONF:
[iisloggingcombined]

DELIMS = " "

FIELDS = date,time,sitename,computername,ip,method,uri-stem,uri-query,port,username,ip,version,(User-Agent),(Cookie),(Referer),host,status,substatus,win32-status,bytes,bytes,time-taken

Somehow i'm still showing my results in (User-Agent) and "uri-query" as a value of "-". Does anyone know why or how this could be occurring?

Thank you!

Tags (3)
0 Karma
1 Solution

Motivator

Then it is quite realistic that I don't know what i'm looking at. I'm more of a network guy, so please forgive me.

View solution in original post

0 Karma

Contributor

The issue here is that your IIS is only logging 17 fields, but your transforms is attempting to extract 22 fields. As a result, the fields don't line up with the extractions.

Either add in the fields in your IIS logging configuration, or remove them from the transforms. Open an IIS log in notepad and look at the header line. Remove any fields from your transforms that are not included in the header of the log and the fields should extract properly.

0 Karma

Motivator

Then it is quite realistic that I don't know what i'm looking at. I'm more of a network guy, so please forgive me.

View solution in original post

0 Karma

Ultra Champion

well, for the uri-query, in the log string you presented the data in the log IS a dash.

As for the user-agent, does it contain '+' instead of ' ' for spaces?

0 Karma