Splunk Search

based on drop down list value

Jasmine
Path Finder

the below are two different drop down list as we have different host and index.
Based on the index selection i do set/unset -show/hide - can we make as single query with single drop down list  based on the value of the dropdownlist which is visible?

 

 

1)  index=aaa (source="/log/test.log"  $host1$ )
          | rex field=name "(?<DB>[^\.]*)"
          | rename DB AS "Database"
		 | table  Database | dedup Database

2) index=bbb (source="/log/test.log"  $host2$ )
          | rex field=name "(?<DB>[^\.]*)"
          | rename DB AS "Database"
		 | table  Database | dedup Database

 

 

 if ddl1 is visible fetch the value and pass to $host1$ to the  query

if ddl2 is visible fetch the value and pass $host2$ to the query

or based on the drop down list value selected can we set value and pass to query to avoid multiple queries for only differnt host/index?

Labels (1)
0 Karma

bowesmana
SplunkTrust
SplunkTrust

I don't quite follow you. but it seems like you only need a single drop down

index=$index$ (source="/log/test.log"  $host$ )
  | rex field=name "(?<DB>[^\.]*)"
  | stats count by DB

What is selecting your index and host fields

Can you share more of your dashboard XML. 

Note that the above doesn't do the rename or table, as they are not necessary - just use DB as the fields for label/value rather than Database.

0 Karma
Got questions? Get answers!

Join the Splunk Community Slack to learn, troubleshoot, and make connections with fellow Splunk practitioners in real time!

Meet up IRL or virtually!

Join Splunk User Groups to connect and learn in-person by region or remotely by topic or industry.

Get Updates on the Splunk Community!

Supercharging Windows Security Detection Performance: Introducing Hybrid Field ...

Windows event logs—from Security auditing and Sysmon to PowerShell script blocks—form the operational backbone ...

Enriching Signals with the OTel Lookup Processor

Introduction Raw telemetry is often incomplete. A log line might record an IP address, but what you really ...

Meet the .conf26 AI Agent Buildathon Winners

At the .conf26 AI Agent Buildathon, Splunk users turned their operational expertise into working AI agents ...