Splunk Search

Why is my timechart overlay axis (second Y axis) not accepting settings correctly?

Motivator

Hi.

On my timechart, I have defined an overlay in the "Chart Overlay" tab of the settings.

View as Axis = On
Title = Custom; "CPU Usage (%)"
Scale = Linear
Interval = ""
Min Value = ""
Max Value = "100"

Now, when I view the timechart, the second y-axis has no title, and the max value is 120, not 100. Any help please?

Thanks for reading.

Path Finder

Hi there,

I encountered the same problem, this is how i fixed it:

No y-axis label:
This seems to happen when the height of the graph is not enough to display the custom title. It seems to fall back to its default at that point. Increase the default height to, say, 450. Then set the axis title again and F5 the page. This fixed it for me.
(Increase default height by adding the following to the source XML of the graph:)

<option name="height">450</option>

Max value issue:
If I want a set scale, filling out all three fields gets it to work. So set an interval, a min value, and a max value. For a 0 - 100 scale I just use the following settings:
Interval:10
Min Value: 0
Max Value: 100

I hope this solves your problem; I don't know what causes it so there might be better / other solutions to this issue.

0 Karma