Splunk Search
Highlighted

Why does a line graph not show data for the current month in my dashboard?

Contributor

is there a XML setting i do not know about because bar graphs show the current month stats and when i pic line, they only show the past months. it looks like its cutting it off.

search:

index=foo host="foofoo" "foofoofoo"=Yes| timechart span=1mon count(this) by "thisfoo"

XML:

<panel>
  <chart>
    <title> Title</title>
    <searchString>index=foo host="foofoo" "foofoofoo"=Yes| timechart span=1mon count(this) by "thisfoo""</searchString>
    <earliestTime>$time.earliest$</earliestTime>
    <latestTime>$time.latest$</latestTime>
    <option name="charting.axisLabelsX.majorLabelStyle.overflowMode">ellipsisNone</option>
    <option name="charting.axisLabelsX.majorLabelStyle.rotation">0</option>
    <option name="charting.axisTitleX.visibility">visible</option>
    <option name="charting.axisTitleY.visibility">visible</option>
    <option name="charting.axisTitleY2.visibility">visible</option>
    <option name="charting.axisX.scale">linear</option>
    <option name="charting.axisY.scale">linear</option>
    <option name="charting.axisY2.enabled">false</option>
    <option name="charting.axisY2.scale">inherit</option>
    <option name="charting.chart">column</option>
    <option name="charting.chart.nullValueMode">gaps</option>
    <option name="charting.chart.sliceCollapsingThreshold">0.01</option>
    <option name="charting.chart.stackMode">default</option>
    <option name="charting.chart.style">shiny</option>
    <option name="charting.drilldown">all</option>
    <option name="charting.layout.splitSeries">0</option>
    <option name="charting.legend.labelStyle.overflowMode">ellipsisMiddle</option>
    <option name="charting.legend.placement">right</option>
  </chart>
</panel>
<panel>
0 Karma
Highlighted

Re: Why does a line graph not show data for the current month in my dashboard?

Contributor

this was a data export error. Splunk was not creating this issue.

View solution in original post

0 Karma