Splunk Search

The fillnull_value option in tstats command

lucas4394
Path Finder

According to Splunk document in "tstats" command, the optional argument, fillnull_value, is available for my Splunk version, 7.2; however, this optional argument doesn't seem working at all. I got an error message: "... The argument 'fillnull_value=NA' is invalid". Does anyone have any clues? Thanks.

| tstats summariesonly=true fillnull_value="NA" count from datamodel=Email.All_Email where * by All_Email.src_user
0 Karma

aberkow
Builder

I just played around with it for awhile - I had initially thought it was because you had "count" and that can never return null, but I tried values as well and that yielded nothing either. If no one else can answer, you have the workaround of adding on line 2 | fillnull value="NA", and should probably open a support ticket. Also, there are no examples of it in usage here: https://docs.splunk.com/Documentation/Splunk/7.2.0/SearchReference/Tstats#Examples which is a bit bothersome.

0 Karma

rvaglid
Explorer

According to the docs this option to `tstats` were introduced in 8.0.0. 
I just recently discovered myself. 🙂

Cheers,
Rolf

0 Karma
Got questions? Get answers!

Join the Splunk Community Slack to learn, troubleshoot, and make connections with fellow Splunk practitioners in real time!

Meet up IRL or virtually!

Join Splunk User Groups to connect and learn in-person by region or remotely by topic or industry.

Get Updates on the Splunk Community!

Laser Bananas and Edge Hubs: Exploring Operational Technology (OT) Data Through a ...

  OT is a different environment to traditional IT and can have interesting challenges when interfacing the ...

Event Series: Mastering AI Tokenomics and Splunk Agent Observability

Beyond the Black Box: Correlating AI Performance and Tokenomics with Splunk Agent Observability   As ...

span_metrics: The OpenTelemetry-Idiomatic Way to See Inside Your Services

You open a trace in Splunk Observability Cloud and everything looks fine. One root span, order-pipeline, with ...