Splunk Search

Splunk sending invalid Email Alerts

rmuraly
Explorer

I am running a query to alert me if the sum of a particular property < 400000. I get alert most times saying the count < 400000. I go and run the query manually for that specific time describred in alert email.. I see that the count is well over 400000. What am I missing here?

index=app host="aws-service-ip*" sourcetype="aws-fht-service-transactions" SVCPushCounter earliest="08/07/2019:19:00:00" latest="08/07/2019:19:30:00"| stats sum(SVCPushCounter) as totalBySvc by Partner| where  (Partner=CVS AND totalBySvc<4000000) )
0 Karma

tiagofbmm
Influencer

You may be getting events arriving later into the instance, what could explain the variation in numbers you;re seeing

Check the _indextime field in those events to verify that

0 Karma
Got questions? Get answers!

Join the Splunk Community Slack to learn, troubleshoot, and make connections with fellow Splunk practitioners in real time!

Meet up IRL or virtually!

Join Splunk User Groups to connect and learn in-person by region or remotely by topic or industry.

Get Updates on the Splunk Community!

Meet the .conf26 AI Agent Buildathon Winners

At the .conf26 AI Agent Buildathon, Splunk users turned their operational expertise into working AI agents ...

Trusted Autonomy in the SOC: A Maturity Journey

AI is compressing attacker timelines and pushing SOC teams beyond human capacity thresholds. The next SOC ...

Supercharging Windows Security Detection Performance: Introducing Hybrid Field ...

Windows event logs—from Security auditing and Sysmon to PowerShell script blocks—form the operational backbone ...