Splunk Search

Splunk not able to recognize the JSON file source type and index it

New Member

I am trying to monitor a folder containing JSON files in it. But, I observed that files are not getting indexed.
When looked into *, the "Number of files" getting updated as new files get added.
But in *'Indexes'
section, "Event Count" remain same 0 and does not increase.
Tried to even search with index="index_name", it does not return any result and shows 0 events.
Even checked the validity of the JSON file on multiple sites and found valid.
Tried to reduce the JSON size as well. Still no luck.

Any suggestion or clue to debug is highly appreciated!
Thanks in advance.

0 Karma

Esteemed Legend
0 Karma
Get Updates on the Splunk Community!

Splunk Observability Cloud | Customer Survey!

If you use Splunk Observability Cloud, we invite you to share your valuable insights with us through a brief ...

Happy CX Day, Splunk Community!

Happy CX Day, Splunk Community! CX stands for Customer Experience, and today, October 3rd, is CX Day — a ...

.conf23 | Get Your Cybersecurity Defense Analyst Certification in Vegas

We’re excited to announce a new Splunk certification exam being released at .conf23! If you’re going to Las ...