Splunk Search

Single value chart

Deepz2612
Explorer

I have a single value chart,who statistical date is as below

<Field_name>

_____________

<field_value>

 

Now when i click on it,the field name has to be passed as the token value to another panel.

How to make that possible.

Please advice

Labels (1)
Tags (1)
0 Karma

to4kawa
Ultra Champion

sample dashboard:

 

 

<dashboard>
  <label>single_test</label>
  <init>
    <unset>$labels$</unset>
  </init>
  <row>
    <panel id="tables2">
      <title>$titles$</title>
      <single>
        <search>
          <query>| tstats count where index=_internal sourcetype=splunkd by PREFIX("name=")
| sort 1 - count
| rename name= as name
| eval {name}=count
| table * name count
</query>
          <earliest>-24h@h</earliest>
          <latest>now</latest>
          <sampleRatio>1</sampleRatio>
          <done>
            <set token="titles">$result.name$</set>
          </done>
        </search>
        <option name="drilldown">all</option>
        <option name="refresh.display">progressbar</option>
        <drilldown>
          <set token="labels">$row.name$</set>
        </drilldown>
      </single>
    </panel>
    <panel id="tables1">
      <html>
         <style>

          #tables1 {
            width: 75% !important;
          }
          #tables2 {
            width: 25% !important;
          }
          #tables2 .panel-title {
            font-size: 32px !important; 
            padding: 12px 12px 7px 12px !important;
            display: flex;
            justify-content: center;
            font-weight: bold !important;
          }
        </style>
        <p>$labels$</p>
      </html>
    </panel>
  </row>
</dashboard>

 

 

0 Karma
Got questions? Get answers!

Join the Splunk Community Slack to learn, troubleshoot, and make connections with fellow Splunk practitioners in real time!

Meet up IRL or virtually!

Join Splunk User Groups to connect and learn in-person by region or remotely by topic or industry.

Get Updates on the Splunk Community!

Supercharging Windows Security Detection Performance: Introducing Hybrid Field ...

Windows event logs—from Security auditing and Sysmon to PowerShell script blocks—form the operational backbone ...

Enriching Signals with the OTel Lookup Processor

Introduction Raw telemetry is often incomplete. A log line might record an IP address, but what you really ...

Meet the .conf26 AI Agent Buildathon Winners

At the .conf26 AI Agent Buildathon, Splunk users turned their operational expertise into working AI agents ...