Splunk Search

Simple splunk table question

mjh
New Member

I am new to Splunk so I'm learning and I know that it can do quite a bit.  I am searching for similar network traffic for users based on our proxy indexes.  I want to know if there is a particular site visited by all of the users in our list of 50 or so.  so user and url are necessary.  I need to pull it from all of their data in our network proxy though.  here is a redacted portion of a search I have honed down to but feel free to suggest something better.

Edit to provide a clear question:  The below search doesn't work, can you provide a different search or edits that would assist me in getting the data I'm looking for?

index=<network one> <userID> IN (userID1,userID2) AND url=* | stats dc(userID) as count by url | where count=2

Labels (1)
0 Karma

gcusello
SplunkTrust
SplunkTrust

Hi @mjh,

what is your question?

if you want to know if the solution you shared is correct, you are the one that can perform the check: have you results?

if yes, it's correct, if not, you have to debug, probably there some error in fields extractions.

Ciao.

Giuseppe

0 Karma
Got questions? Get answers!

Join the Splunk Community Slack to learn, troubleshoot, and make connections with fellow Splunk practitioners in real time!

Meet up IRL or virtually!

Join Splunk User Groups to connect and learn in-person by region or remotely by topic or industry.

Get Updates on the Splunk Community!

Supercharging Windows Security Detection Performance: Introducing Hybrid Field ...

Windows event logs—from Security auditing and Sysmon to PowerShell script blocks—form the operational backbone ...

Enriching Signals with the OTel Lookup Processor

Introduction Raw telemetry is often incomplete. A log line might record an IP address, but what you really ...

Meet the .conf26 AI Agent Buildathon Winners

At the .conf26 AI Agent Buildathon, Splunk users turned their operational expertise into working AI agents ...