Splunk Search

Search query for showing Connection attempts per user to same Destination

neerajs_81
Builder

Hello All,
I have a query that searches the Windows Security Logs and shows results in the following format using a stats function .  As you can see , i am grouping connection attempts from multiple users to a particular Dest .
Also,  the "Connection Attempts" takes into account the total # for all the users listed under "User" per row.

 

index=xxx source="WinEventLog:Security" EventCode=4624
| stats values(dest_ip), values(src), values(src_ip),values(user), dc(user) as userCount, count as "Connection Attempts" by dest

 

DestDest_IPSrcSRC_IPuserCountUser Connection Attempts
XXXXXXXXXXXX3User A User B User C9
XXXXXXXXXXXX2User D User E78
       

 

I would like to show how many connection attempts were made by each user.  How to segregate this data per user ?

Labels (2)
0 Karma

PickleRick
SplunkTrust
SplunkTrust

If you aggregate, there's no way to "unaggregate" so instead of doing values(user) you'd need to just do your stats "by dest user". But then you lose the overall aggregation on dest.

Sorry, these are two different aggregations and you have to do them separately if you want to have two charts - one by user and one by dest.

Got questions? Get answers!

Join the Splunk Community Slack to learn, troubleshoot, and make connections with fellow Splunk practitioners in real time!

Meet up IRL or virtually!

Join Splunk User Groups to connect and learn in-person by region or remotely by topic or industry.

Get Updates on the Splunk Community!

Why Splunk Customers Should Attend Cisco Live 2026 Las Vegas

Why Splunk Customers Should Attend Cisco Live 2026 Las Vegas     Cisco Live 2026 is almost here, and this ...

What Is the Name of the USB Key Inserted by Bob Smith? (BOTS Hint, Not the Answer)

Hello Splunkers,   So you searched, “what is the name of the usb key inserted by bob smith?”  Not gonna lie… ...

Automating Threat Operations and Threat Hunting with Recorded Future

    Automating Threat Operations and Threat Hunting with Recorded Future June 29, 2026 | Register   Is your ...