Splunk Search

Reverse DNS lookups not working

mundus
Path Finder

I'm following the instructions for implementing a reverse DNS lookup at search time. I either get an error saying the fields couldn't be found or I don't get the output I'm expecting.

I copied the external_lookup.py to /etc/apps/search/bin

Transforms.conf:

[dnslookup]
external_cmd = external_lookup.py host ip
fields_list = host, ip

Props.conf:

[nessus]
LOOKUP-rdns = dnslookup ip OUTPUT host AS hostname

I also tried OUTPUTNEW per the example in:

http://docs.splunk.com/Documentation/Splunk/4.3/Knowledge/Addfieldsfromexternaldatasources#Set_up_a_...

What am I doing wrong here? The hostname field is empty if I run a search such as:

sourcetype=nessus NOT timestamps | dedup host | rename dest_ip AS ip | lookup dnslookup ip | table ip, hostname

Thx.

Tags (1)
0 Karma

are0002
Path Finder

Try

[nessus]
LOOKUP-rdns = dnslookup ip AS OUTPUT host AS hostname

0 Karma
Get Updates on the Splunk Community!

Last Chance to Submit Your Paper For BSides Splunk - Deadline is August 12th!

Hello everyone! Don't wait to submit - The deadline is August 12th! We have truly missed the community so ...

Ready, Set, SOAR: How Utility Apps Can Up Level Your Playbooks!

 WATCH NOW Powering your capabilities has never been so easy with ready-made Splunk® SOAR Utility Apps. Parse ...

DevSecOps: Why You Should Care and How To Get Started

 WATCH NOW In this Tech Talk we will talk about what people mean by DevSecOps and deep dive into the different ...