Splunk Search

Reordering columns not working through API

whateverwhouare
New Member

I want to reorder my columns. I tried both table and fields, and they seemed to work through the web UI, but when I tried it through the REST API the order did not change at all.

Is there any known problem with reordering through REST API, or can anyone point out what I'm doing wrong? Below is my query.

index=na1 host=*app* logRecordTypeseclk=1 earliest=-5h tableEnumOrId=Contact OR tableEnumOrId=CollaborationGroup | where rank < 10 | stats count by rank, tableEnumOrId | table count, tableEnumOrId, rank

EDIT:

I asked this a while ago but I think the issue is somehow stats is affecting table. When I change stats count by rank, tableEnumOrId to stats count by tableEnumOrId, rank, the output order changed accordingly. But no matter how I change the ordering of the column names in table, nothing changes.

Is this a known issue? Or am I just doing something wrong?

0 Karma

nicolas_perreau
Explorer

Hi!

I'm having the same issue with REST and I do not see anyway to fix it so far.

I've just upgraded from Splunk 5.0.5 to 6.2.2 and noticed the behavior.

0 Karma
*NEW* Splunk Love Promo!
Snag a $25 Visa Gift Card for Giving Your Review!

It's another Splunk Love Special! For a limited time, you can review one of our select Splunk products through Gartner Peer Insights and receive a $25 Visa gift card!

Review:





Or Learn More in Our Blog >>