Splunk Search

Issue while using log mode in column chart

sdkp03
Path Finder

I have created a metrics dashboard in which I have configured column chart. By default scale used is "Linear", this had issues as lower values were not plotted. As a fix configured the metrics to use "Log" scale, which did meet requirements. But the issue now is that when the count value spans around 1,3,7,14 all these values are maxed at 1. It's weird because expectation is that the plotting would be 0,1,10,100 and the values should have been plotted accordingly. Not sharing query as this is purely based on the count value. Would someone know if this is expected behavior or is there some config that should be tweaked which i might have missed. Metrics dashboard config mentioned below if it helps.:

<row>
<panel>
<title>Metrics Panel</title>
<chart>
<search>
<query>index=abcx "logData.logType"=INFO | timechart span=$slice$ count(feedName) </query>
<earliest>$time_range$</earliest>
<latest>now</latest>
</search>
<option name="charting.chart">column</option>
<option name="charting.axisTitleX.text">Timestamp</option>
<option name="charting.axisY.scale">log</option>
<option name="charting.chart.showDataLabels">all</option>
</chart>
</panel>
</row>

Labels (1)

bowesmana
SplunkTrust
SplunkTrust

Never had a problem with using log and just with a simple example based on your example, the values don't behave as you describe, i.e. all numbers appeared to plot sensible on log scale, including the numbers you mention.

<dashboard>
  <row>
    <panel>
      <title>Metrics Panel</title>
      <chart>
        <search>
          <query>index=_internal
          | timechart span=1s count</query>
          <earliest>-10s</earliest>
          <latest>now</latest>
        </search>
        <option name="charting.chart">column</option>
        <option name="charting.axisTitleX.text">Timestamp</option>
        <option name="charting.axisY.scale">log</option>
        <option name="charting.chart.showDataLabels">all</option>
      </chart>
    </panel>
  </row>  
</dashboard>

 

0 Karma

sdkp03
Path Finder

I am trying this on splunk version 7.2.7. May I know the version on which you tried, just trying to understand the difference.  Snapshot attached below for your reference.

sdkp03_0-1603160211373.png

 

0 Karma

bowesmana
SplunkTrust
SplunkTrust

It's 8.0.1

It looks like Splunk thinks your Y-axis has a max value of 1. Note the black box showing the uptick mark with the value 7 - which is showing it is off the Y-axis scale. I forced my Y axis to be max 1 and get the same type of display, i.e. below it shows 3 and my scale is max 1.

bowesmana_1-1603167537534.png

Have you tried checking your Y axis and forcing it to be some value > 1

 

0 Karma

sdkp03
Path Finder

Yes have verified both minimum and max value. Both are blank. This behavior is observed only when the value is less than 14. Snapshot attached below for your reference. 

sdkp03_0-1603169692678.png

 

0 Karma
Get Updates on the Splunk Community!

Splunk Forwarders and Forced Time Based Load Balancing

Splunk customers use universal forwarders to collect and send data to Splunk. A universal forwarder can send ...

NEW! Log Views in Splunk Observability Dashboards Gives Context From a Single Page

Today, Splunk Observability releases log views, a new feature for users to add their logs data from Splunk Log ...

Last Chance to Submit Your Paper For BSides Splunk - Deadline is August 12th!

Hello everyone! Don't wait to submit - The deadline is August 12th! We have truly missed the community so ...