Splunk Search

How to prevent tstats from truncating large fields

rhobby
New Member

I have an accelerated data model with a field with large strings in it.
When I use the spl

| data model dm_name ds_name search | table *

I can see the whole fields.

When I use tstats:

| tstats latest (_time) as _time latest (ds_name. data) as data from datamodel=dm_name.ds_name
where (nodename = ds_name)
groupby ds_name. id prestats=true

the data fields are truncated.

I tried to change [stats] maxvaluesize in limits.conf without success. There seems to be no such config for tstats.

How can I prevent tstats from truncating large fields?

Labels (1)
0 Karma

schplunk_meiste
Engager

"Accelerated fields have a limitation of 1024 bytes per entry, so you cannot use fields that have more than 1024 bytes"

https://dev.splunk.com/enterprise/docs/developapps/manageknowledge/kvstore/usingconfigurationfiles/

0 Karma
Got questions? Get answers!

Join the Splunk Community Slack to learn, troubleshoot, and make connections with fellow Splunk practitioners in real time!

Meet up IRL or virtually!

Join Splunk User Groups to connect and learn in-person by region or remotely by topic or industry.

Get Updates on the Splunk Community!

Why Splunk Customers Should Attend Cisco Live 2026 Las Vegas

Why Splunk Customers Should Attend Cisco Live 2026 Las Vegas     Cisco Live 2026 is almost here, and this ...

What Is the Name of the USB Key Inserted by Bob Smith? (BOTS Hint, Not the Answer)

Hello Splunkers,   So you searched, “what is the name of the usb key inserted by bob smith?”  Not gonna lie… ...

Automating Threat Operations and Threat Hunting with Recorded Future

    Automating Threat Operations and Threat Hunting with Recorded Future June 29, 2026 | Register   Is your ...