Splunk Search

How to map metadata ACS value to a public domain?

Engager

Hi, I have deployed a splunk enterprise server on AWS ec2 so that I have a public domain name.

When I configure the IDP, I need to enter the ACS value from Service Provider splunk.
But my issue here is that in my metadata, the ACS value shows my server hostname when I fill it in IDP, it cannot be redirected back to Splunk after authentication. I changed the hostname with the domain name in Splunk settings, but the metadata did not change.

How can I map them so that IDP could redirect back to Splunk?
Thanks

0 Karma

Esteemed Legend

I am sure that I am not understanding your problem so this may not help but you can control how any Splunk forwarder self-identifies with these commands:

$SPLUNK_HOME/bin/splunk set servername
$SPLUNK_HOME/bin/splunk set default-hostname

There are also show versions of these commands:

$SPLUNK_HOME/bin/splunk show servername
$SPLUNK_HOME/bin/splunk show default-hostname
0 Karma

Contributor

Once I have a similar problem with metadata, then I use Nginx to control the redirections.

0 Karma