Splunk Search

How to check a table for multiple mac addresses with the same IP

jhick
Observer

Currently my splunk search to get a list of macs of the security cameras with their respective IP is 

index = dhcp 00:04:7d 10.101.240.* |table dest_mac, dest_ip |dedup dest_ip | dedup dest_mac

How would I get it to check for  multiple mac addresses with the same IP. This will indicate that the IP is not fixed.

Thank you!

Labels (4)
Tags (4)
0 Karma

abowesman
Explorer

Try

 

| stats values(dest_mac) as MacAddresses by dest_ip

 

0 Karma
Got questions? Get answers!

Join the Splunk Community Slack to learn, troubleshoot, and make connections with fellow Splunk practitioners in real time!

Meet up IRL or virtually!

Join Splunk User Groups to connect and learn in-person by region or remotely by topic or industry.

Get Updates on the Splunk Community!

[Puzzles] Solve, Learn, Repeat: Character substitutions with Regular Expressions

This challenge was first posted on Slack #puzzles channelFor BORE at .conf23, we had a puzzle question which ...

Splunk Community Badges!

  Hey everyone! Ready to earn some serious bragging rights in the community? Along with our existing badges ...

[Puzzles] Solve, Learn, Repeat: Matching cron expressions

This puzzle (first published here) is based on matching timestamps to cron expressions.All the timestamps ...