Splunk Search

How can I create this Splunk Query for a specific domain an display the list of the traffic going to that domain address as a table?

ashishlal82
Explorer

I have been out of date with building Splunk queries and I would need your help.
1) For a specific domain, let's say "xyz.com", how can I display the list of the traffic going to that domain address. I want it to be displayed as a table with time,src_ip, username , dest_ip and URL.

0 Karma

somesoni2
Revered Legend

We probably need to see some sample data and description of fields available from that data. My initial thought would be that you can filter your result for a particular domain and do the table, like this:

index=foo sourcetype=bar URL=*xyz.com* 
| table _time src_ip username dest_ip URL
0 Karma
Got questions? Get answers!

Join the Splunk Community Slack to learn, troubleshoot, and make connections with fellow Splunk practitioners in real time!

Meet up IRL or virtually!

Join Splunk User Groups to connect and learn in-person by region or remotely by topic or industry.

Get Updates on the Splunk Community!

Persistent Queue at TcpOut — One of Splunk's Most Practical Features

Splunk introduced persistent queueing at the tcpout layer as one of the most practical resilience features in ...

Skip the Awkward Silence: Have a .conf-ersation at .conf26

Picture this. You arrive at .conf26 already having your socializing and networking plans mapped out. No ...

Rethinking Zero Trust: From Product Purchases to Logical Control Evidence

Note: This post outlines a proposed architecture and serves as an interest check. If we secure commitments ...