Splunk Search

Fisher test using R for data in Splunk

melonman
Motivator

Hi

I want to perform fisher test on data in Splunk. The table passed to R looks like this:

index=summary stats=conversion_rate 
| table _time purchase view
| fields - _time

purchase view
-------- ----
     747 2463
     537 2545

I want to to the fisher.t(input), to compare 1st line and 2nd line, and get p-value as a result.

but I got stuck at a very basic step, creating matrix from data passed from Splunk.
Could anyone give me a sample for this?

Tags (1)
0 Karma
1 Solution

clongo01
Engager

Hello. You will have to format your data in a table at then end of your search. The R app will automatically assign that table as the input to your R command. It would look something like this.

index=summary stats=conversion_rate | table purchase view | r "
result = fisher.test(input)
output = data.frame(Result=c(result))
"

Your output will be two columns because it is capturing the confidence bounds as well and the p-value. If you want to return just the p-value from the fisher test change the last line to be output = data.frame(Result=c(result$p.value)).

Hope this helps!

View solution in original post

clongo01
Engager

Hello. You will have to format your data in a table at then end of your search. The R app will automatically assign that table as the input to your R command. It would look something like this.

index=summary stats=conversion_rate | table purchase view | r "
result = fisher.test(input)
output = data.frame(Result=c(result))
"

Your output will be two columns because it is capturing the confidence bounds as well and the p-value. If you want to return just the p-value from the fisher test change the last line to be output = data.frame(Result=c(result$p.value)).

Hope this helps!

Got questions? Get answers!

Join the Splunk Community Slack to learn, troubleshoot, and make connections with fellow Splunk practitioners in real time!

Meet up IRL or virtually!

Join Splunk User Groups to connect and learn in-person by region or remotely by topic or industry.

Get Updates on the Splunk Community!

Meet the .conf26 AI Agent Buildathon Winners

At the .conf26 AI Agent Buildathon, Splunk users turned their operational expertise into working AI agents ...

Trusted Autonomy in the SOC: A Maturity Journey

AI is compressing attacker timelines and pushing SOC teams beyond human capacity thresholds. The next SOC ...

Supercharging Windows Security Detection Performance: Introducing Hybrid Field ...

Windows event logs—from Security auditing and Sysmon to PowerShell script blocks—form the operational backbone ...