Splunk Search

Does Splunk do Internet Name Resolution?

garciatdg
New Member

I am doing an experiment at home to capture Internet traffic for all of my devices in my house connected to my home wi-fi. I heard in a conference that a guy setup Splunk Streaming on his splunk instance and was able to capture all traffic between his wireless router and any device in his house.

sourcetype="stream:ip" src_ip="192.168.1.16"
| stats count by dest_ip

I put this quick query together but I don't think I'm capturing everything, but I'd also like to have splunk resolve the Dest_IP
For example, if I pull up Google.com, I'd like to see in a Splunk Table "google.com" and not "172.217.5.78"

my results are as follows

alt text

Tags (1)
0 Karma

woodcock
Esteemed Legend

Yes, assuming DNS is accessible by the search head, just add this to the bottom:

... | lookup dnslookup clientip AS dest_ip
0 Karma
Got questions? Get answers!

Join the Splunk Community Slack to learn, troubleshoot, and make connections with fellow Splunk practitioners in real time!

Meet up IRL or virtually!

Join Splunk User Groups to connect and learn in-person by region or remotely by topic or industry.

Get Updates on the Splunk Community!

Think Like an Architect: Introducing the Splunk Certified Cybersecurity Defense ...

In cybersecurity, defenders respond to threats. Architects design the systems that stop them.    As ...

Index This | What has goals but no motivation?

June 2026 Edition  Hayyy Splunk Education Enthusiasts and the Eternally Curious!   We’re back with this ...

Deep Dive: Accelerate threat investigation with Splunk’s AI Assistant in Security

AI is one of the biggest topics in the market today, and for security teams, its value goes far beyond the ...