Splunk Search

DB Connect does not work when enableSplunkdSSL=false

yitzarad
Path Finder

Hi.

For some reasons, I turned off SSL for Splunk REST API. Everything is fine, except the Splunk DB Connect app.

jbridge is failing to start, after the SSL change:

DEBUG  Setting up java Environment: app=dbx, cfg_name=java, cfg_stanza=java, java_home=None
DEBUG  JAVA_HOME=C:\Program Files\Java\jre7
INFO   Checking for obsolete java libraries in C:\Program Files\Splunk\etc\apps\dbx\bin\lib
DEBUG  Starting JavaBridgeServer...
DEBUG  Executing (native) CMD C:\Program Files\Java\jre7\bin\java.exe -cp .....
       -Dsplunk.app.ctx=dbx com.splunk.bridge.JavaBridgeServer 1368
INFO   Started JavaBridgeServer PID=3868
DEBUG  win32 handler registered
ERROR  Java process returned error code 1! Error: initializing Splunk context...
       Exception in thread "main" com.splunk.config.SplunkConfigurationException:
       IO Error while reading configuration from Splunkd: javax.net.ssl.SSLException:
       Unrecognized SSL message, plaintext connection?
           at com.splunk.config.rest.RESTAdapter.request(RESTAdapter.java:195)
           at com.splunk.config.rest.RESTAdapter.readConfig(RESTAdapter.java:203)
           ...
           at com.splunk.env.SplunkContext.getConfigStanza(SplunkContext.java:313)
           at com.splunk.env.SplunkContext.initialize(SplunkContext.java:128)
           at com.splunk.bridge.JavaBridgeServer.main(JavaBridgeServer.java:34)
 ...
DEBUG  JavaBridgeServer terminated
  • Did I miss a config options for dbx app, which sets SSL to false?
  • If there's no such options, is this case a known issue?
  • Any suggested work around?

lukejadamec
Super Champion

According to the documentation, EnableSplunkdSSL=true is a mandatory configuration setting.

From: http://docs.splunk.com/Documentation/DBX/1.0.11/DeployDBX/Installtheconnector
Configure Splunk DB Connect

"Note: To run DB Connect successfully, splunkd HTTPS must be enabled. In the $SPLUNK_HOME/etc/system/default/server.conf configuration file, enableSplunkdSSL must be set to true:

[sslConfig]

enableSplunkdSSL = true"

0 Karma

yitzarad
Path Finder

hi.
a new version of dbx (1.1) was released, but this constraint is still alive.

won't this issue be fix sometime? is there any significant rationale for this?

0 Karma

araitz
Splunk Employee
Splunk Employee

I was able to reproduce and opened DBX-195. I will update here when I have more information.

yitzarad
Path Finder

Hi. do you have any time estimation for this to be solved and officially released?

0 Karma
Did you miss .conf21 Virtual?

Good news! The event's keynotes and many of its breakout sessions are now available online, and still totally FREE!