Splunk Search

Correlation between 3 sources with 2 IDs

jsp
Engager

I have 3 sourcetypes, and am trying to correlate them based off of 2 IDs. Here is an oversimplified example of the data and what I am trying to achive:

index=books sourcetype=titles
fields: title   title_id    queue_id

index=books sourcetype=authors
fields: author  title_id

index=books sourcetype=locations
fields: location    queue_id

What is the easiest way to get title, author, location, title_id, queue_id in one row of results, based on a search for a title?

Tags (2)
0 Karma

alacercogitatus
SplunkTrust
SplunkTrust

index=books sourcetype=titles title=TITLE | join type=outer title_id [search index=books sourcetype=authors ]|join type=outer queue_id [search index=books sourcetype=locations]| stats count by title author location title_id queue_id

Should get you started. join's are a little ineffective, but if you make them static lookups, they would run faster.

0 Karma
Got questions? Get answers!

Join the Splunk Community Slack to learn, troubleshoot, and make connections with fellow Splunk practitioners in real time!

Meet up IRL or virtually!

Join Splunk User Groups to connect and learn in-person by region or remotely by topic or industry.

Get Updates on the Splunk Community!

Meet the .conf26 AI Agent Buildathon Winners

At the .conf26 AI Agent Buildathon, Splunk users turned their operational expertise into working AI agents ...

Trusted Autonomy in the SOC: A Maturity Journey

AI is compressing attacker timelines and pushing SOC teams beyond human capacity thresholds. The next SOC ...

Supercharging Windows Security Detection Performance: Introducing Hybrid Field ...

Windows event logs—from Security auditing and Sysmon to PowerShell script blocks—form the operational backbone ...