Splunk Search

Comparing 2 searches using different sources?

ckutach
Engager

I am trying to make 2 searches using different indexes and sources

The first search is looking for all entries with "message sent" and the "Message Id". The second search is looking for the "Message Id" and "message sent".

 I am trying to find the number of messages that were sent but not received by comparing the message ID, and list the message IDs that were not sent

Example Attempt:

(index = exampleindex1 source = examplesource1 ("message sent" AND "MessageId")  
OR (index = exampleindex2 source = examplesource2 ("message received" AND "MessageId") 
| rex field=_raw "MessageId:(?<messageId>[\S]+)\s.*" 
| stats values(*) as * by messageId

 

Labels (1)
0 Karma

yuanliu
SplunkTrust
SplunkTrust

Something like

(index = exampleindex1 source = examplesource1 ("message sent" AND "MessageId") )
OR (index = exampleindex2 source = examplesource2 ("message received" AND "MessageId") )
| rex field=_raw "MessageId:(?<messageId>[\S]+)\s.*"
| rex "\bmessage\s+<?type>(sent|received)\b" ``` no need to specify field if _raw ```
| stats dc(messageId) as msgCount by type
| eval msgCount = if(type == "received", -msgCount, msgCount)
| stats sum(msgCount) as sent_not_received

You missed a couple parenthesis.

Tags (2)
0 Karma
Got questions? Get answers!

Join the Splunk Community Slack to learn, troubleshoot, and make connections with fellow Splunk practitioners in real time!

Meet up IRL or virtually!

Join Splunk User Groups to connect and learn in-person by region or remotely by topic or industry.

Get Updates on the Splunk Community!

Meet the .conf26 AI Agent Buildathon Winners

At the .conf26 AI Agent Buildathon, Splunk users turned their operational expertise into working AI agents ...

Trusted Autonomy in the SOC: A Maturity Journey

AI is compressing attacker timelines and pushing SOC teams beyond human capacity thresholds. The next SOC ...

Supercharging Windows Security Detection Performance: Introducing Hybrid Field ...

Windows event logs—from Security auditing and Sysmon to PowerShell script blocks—form the operational backbone ...