Splunk Search

Case insensitive field value results in a count

sdettling
New Member

How can I make the results of a count on the user field case insensitive?

index=winevents sourcetype="WinEventLog:Security" Keywords="Audit Failure" | fields user, count

I get results like:

User:
JDoe
jdoe
MSmith
msmith

I'd rather that user field consolidate those values/

I think this is done with the eval argument, but I don't know the syntax.

Tags (1)
0 Karma

martin_mueller
SplunkTrust
SplunkTrust

I think you meant | stats count by user rather than | fields?

That being said, yeah - stats is case sensitive. In fact, virtually everything in Splunk searches is case sensitive except the search command with regards to values... so you can | search log_level="error" and find ERROR, but can't | search loG_level="error" because field names are always case sensitive and can't | where log_level="error" because it's not search.

You can normalize field values to either lower or upper case before sending them into stats like this:

... | eval user = lower(user) | stats count by user
Got questions? Get answers!

Join the Splunk Community Slack to learn, troubleshoot, and make connections with fellow Splunk practitioners in real time!

Meet up IRL or virtually!

Join Splunk User Groups to connect and learn in-person by region or remotely by topic or industry.

Get Updates on the Splunk Community!

Announcing Modern Navigation: A New Era of Splunk User Experience

We are excited to introduce the Modern Navigation feature in the Splunk Platform, available to both cloud and ...

Modernize your Splunk Apps – Introducing Python 3.13 in Splunk

We are excited to announce that the upcoming releases of Splunk Enterprise 10.2.x and Splunk Cloud Platform ...

Step into “Hunt the Insider: An Splunk ES Premier Mystery” to catch a cybercriminal ...

After a whole week of being on call, you fell asleep on your keyboard, and you hit a sequence of buttons that ...