Splunk Search

Cant get line break \n to create new lines between results when emailed?

dlespron
Path Finder

I know I must be missing something simple and have searched here trying multiple things but still can't get this to work. I get the results just fine and they come via email, but I need a blank line between each of the results in order to make easier for the end user to view. Can someone please help?

This is basically what I have right now:

$SearchText$ | rex mode=sed "s/\n/\n\n/g" | rex mode=sed "s/\x1/ /g" | sort _raw | table _raw | sendemail 

Thanks!

derekarnold
Communicator

The default format of a sendemail is a table format. try using

| sendemail format=raw

Failing that, you may have to use the options to attach a CSV or PDF instead.

0 Karma
Get Updates on the Splunk Community!

Registration for Splunk University is Now Open!

Are you ready for an adventure in learning?   Brace yourselves because Splunk University is back, and it's ...

Splunkbase | Splunk Dashboard Examples App for SimpleXML End of Life

The Splunk Dashboard Examples App for SimpleXML will reach end of support on Dec 19, 2024, after which no new ...

Understanding Generative AI Techniques and Their Application in Cybersecurity

Watch On-Demand Artificial intelligence is the talk of the town nowadays, with industries of all kinds ...